Please start using our more robust New Forum, we have put this old forum in archive mode. Thanks.


Welcome Guest Search | Active Topics | Log In

Tag as favorite
Announcing Release of jQuery Gantt Package 3.0
support
#1 Posted : Wednesday, September 25, 2013 1:10:20 PM

Posts: 469

We are excited to announce the release of our jQuery Gantt Package, version 3.0.

This updates includes some much sought after features like Printing, and we have also drasitically optimized and reduced the size of our JS files. There is also a brand new feature "Browse To Task Cues" which has received some very good buzz already. Remember to turn of this feature in your gantts.

New Features
- Printing support.
- Browse to tasks cues feature - to indicate and quickly browse to a horizotntally, visually hidden task.
- Resizing bars on the left in FlexyGantt.
- Selectively making some tasks read-only through IsTaskReadOnlyBinding in GanttControl.
- AutoExpandNodes option in FlexyGantt, to control the expand and collapse state before the FlexyGantt loads.
- Mouse wheel zoom in chart.
- CustomProgressCalculation to customize summary progress calculation logic.
- New LayoutUpdated Method to refresh the sizes of the gantt elements.
- Suport for jQuery 2.0
- Improved ASP.NET and MVC Wrapper APIs
- Optimized Minified Source (brings size to half of what it was).
- Console Logs to indicate errors and better warning text on load.


Bug Fixes
- BaseTimeUnitWidthMinimum can go down all the way to 0.
- Fix for setting datasoure after FlexyGantt created won't update the Gantt height and other options.
- Fix for loading gantt when the element's dispaly property is none.
- Sync the Milestone bar centered with timeline timeunits.
- Tooltip doesnt work correctly (when moving mouse from right to the left)
- Bug fix in Critical Path calculation
- Parent task's end time binding issue
- Fixing alternative row background height issue
- Context menu related fixes when there were multiple gantts.
- etc.

Upgrading from 2.8 or older versions to 3.0
Though 3.0 is fully compabile with 2.8, we recommed some changes that will help optimize the JS and CSS referenes in your app. Please refer these topics for more info:

- Upgrading HTML apps from 2.8 or earlier to 3.0

- Upgrading ASP.NET apps from 2.8 or earlier to 3.0
- Upgrading MVC apps from 2.8 or earlier to 3.0

Hope you enjoy working with this version as much as we did building this.

Thanks
RadiantQ Development Team
Tag as favorite
Forum Jump  
Please Email support@radiantq.com for any issues

ugg boots outlet cheap ugg sale ugg boots clearance ugg boots sale ugg boots cheap ugg boots for women uggs for cheap ugg shops cheap ugg boots cheap uggs Official Ugg Outlet ugg Store Buy Cheap UGGs ugg boots uk ugg boots usa ugg Online uggs on sale ugg outlets cheap ugg boot Discount UGG Boots discount uggs